TRC is primarily funded by ad revenue. If you like the content you find here, please do not block our ads. Thank you.
Page 1 of 2 12 LastLast
Results 1 to 15 of 19

Thread: Mondeo Screen Wash Problem

  1. #1
    Retired. Yorick's Avatar
    Join Date
    Jan 2008
    Location
    Too Fast For Neil Hodgson
    Posts
    22,279
    Like
    48
    Liked 62 in 50 posts

    Question Mondeo Screen Wash Problem

    The windscreen washer has packed up and it's got me baffled

    The rear screen washer does work though. And there doesn't seem to be a fuse specifically for the front washers.

    One little clue maybe, but when I do press the washer stalk, it does make the radio crackle.

    Any ideas please ?
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!


  2. TRC is primarily funded by ad revenue. If you like the content you find here, please do not block our ads. Thank you.
  3. #2
    Should Get Out More DefTrap's Avatar
    Join Date
    Jan 2008
    Location
    Roger Barlow's Tour of Europe
    Posts
    19,494
    Like
    78
    Liked 71 in 46 posts

    Default Re: Mondeo Screen Wash Problem

    Anything else not working?
    Sometimes one fuse services a system that is otherwise unmarked. I'd check ALL fuses just to be sure.

  4. #3
    Really Bored wheelnut's Avatar
    Join Date
    Jan 2008
    Location
    Hanging by a thread
    Posts
    3,574
    Like
    9
    Liked 11 in 7 posts
    Blog Entries
    2

    Default Re: Mondeo Screen Wash Problem

    If it makes the radio crackle it sounds like the pump is working. Stick your head under the bonnet and listen for the pump while someone operates the washer - it may well be a dislodged or split pipe

  5. #4
    Retired. Yorick's Avatar
    Join Date
    Jan 2008
    Location
    Too Fast For Neil Hodgson
    Posts
    22,279
    Like
    48
    Liked 62 in 50 posts

    Default Re: Mondeo Screen Wash Problem

    Quote Originally Posted by wheelnut View Post
    If it makes the radio crackle it sounds like the pump is working. Stick your head under the bonnet and listen for the pump while someone operates the washer - it may well be a dislodged or split pipe
    The pump is audible in the car normally.
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!

  6. #5
    Retired. Yorick's Avatar
    Join Date
    Jan 2008
    Location
    Too Fast For Neil Hodgson
    Posts
    22,279
    Like
    48
    Liked 62 in 50 posts

    Default Re: Mondeo Screen Wash Problem

    Quote Originally Posted by DefTrap View Post
    Anything else not working?
    Sometimes one fuse services a system that is otherwise unmarked. I'd check ALL fuses just to be sure.
    They're a right pain to get to LOL
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!

  7. #6
    Really Bored Wolfzx12r's Avatar
    Join Date
    Feb 2008
    Location
    Wirral
    Posts
    3,582
    Like
    2
    Liked 3 in 3 posts

    Default Re: Mondeo Screen Wash Problem

    Does it have its own bottle for the rear or does it run off the front?

    If it does have its own bottle in the boot “that’s why the rear is working”.

    The motor on the front bottle could be OK but the pump itself is fukc causing a strain on the motor which upsets your electrics (hence a crackle radio.)

    Or

    The pipes that feed the water jets could be blocked having the same result as above.

    Or

    The water jets are blocked; Use a pin to clean out.
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!

  8. #7
    A Bit Bored Tiff's Avatar
    Join Date
    Feb 2008
    Location
    fife
    Posts
    91
    Like
    0
    Liked 0 in 0 posts

    Default Re: Mondeo Screen Wash Problem

    Mondeo's were a pain for the filters inside the washer pump getting blocked with crystalised screen wash, take the pump out the bottle,dry your arm off then poke a hole in the filter. Rear wash is a seperate pump.

  9. #8
    Retired. Yorick's Avatar
    Join Date
    Jan 2008
    Location
    Too Fast For Neil Hodgson
    Posts
    22,279
    Like
    48
    Liked 62 in 50 posts

    Default Re: Mondeo Screen Wash Problem

    Quote Originally Posted by Wolfzx12r View Post
    Does it have its own bottle for the rear or does it run off the front?

    If it does have its own bottle in the boot “that’s why the rear is working”.

    The motor on the front bottle could be OK but the pump itself is fukc causing a strain on the motor which upsets your electrics (hence a crackle radio.)

    Or

    The pipes that feed the water jets could be blocked having the same result as above.

    Or

    The water jets are blocked; Use a pin to clean out.
    There is only 1 bottle, so I assume 1 pump ?
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!

  10. #9
    Retired. Yorick's Avatar
    Join Date
    Jan 2008
    Location
    Too Fast For Neil Hodgson
    Posts
    22,279
    Like
    48
    Liked 62 in 50 posts

    Default Re: Mondeo Screen Wash Problem

    Quote Originally Posted by Tiff View Post
    Mondeo's were a pain for the filters inside the washer pump getting blocked with crystalised screen wash, take the pump out the bottle,dry your arm off then poke a hole in the filter. Rear wash is a seperate pump.
    If there is only 1 bottle, will there be separate pumps ?
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!

  11. #10
    Really Bored wheelnut's Avatar
    Join Date
    Jan 2008
    Location
    Hanging by a thread
    Posts
    3,574
    Like
    9
    Liked 11 in 7 posts
    Blog Entries
    2

    Default Re: Mondeo Screen Wash Problem

    Have an accidental thanks

    Quote Originally Posted by Yorick View Post
    The pump is audible in the car normally.
    So you can't hear it now?

    Quote Originally Posted by Yorick View Post
    If there is only 1 bottle, will there be separate pumps ?
    Either that of some complicated solenoid device to redirect the flow. Simpler to have two pumps.

  12. #11
    Retired. Yorick's Avatar
    Join Date
    Jan 2008
    Location
    Too Fast For Neil Hodgson
    Posts
    22,279
    Like
    48
    Liked 62 in 50 posts

    Default Re: Mondeo Screen Wash Problem

    Quote Originally Posted by wheelnut View Post
    Have an accidental thanks



    So you can't hear it now?



    Either that of some complicated solenoid device to redirect the flow. Simpler to have two pumps.
    2 pumps makes more sense

    PS, this morning I tried the washer to see if I could see/hear anything and the buggers worked . But only the once and now nothing again.

    I'l give the pump a clean tonight
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!

  13. #12
    At Work littleredrooster's Avatar
    Join Date
    Jan 2008
    Location
    Midlands
    Posts
    1,384
    Like
    0
    Liked 0 in 0 posts

    Default Re: Mondeo Screen Wash Problem

    If it's the same as the later Mundanos, there's only one pump which spins one way for the front jets, and t'other way for the rear jet. So it could either be a blockage in the outlet from the pump (likely) or summat in the motor/impellor letting it spin in only one direction (possible) or an electrical fault with the motor (less likely).

  14. #13
    A Bit Bored
    Join Date
    Jan 2008
    Location
    Lowestoft
    Posts
    161
    Like
    0
    Liked 0 in 0 posts

    Default Re: Mondeo Screen Wash Problem

    I've had the hose get blocked on my Mondeo and then the pressure blows it off the pump. It's a right bugger to get to to put it back on.

  15. #14
    Really Bored Wolfzx12r's Avatar
    Join Date
    Feb 2008
    Location
    Wirral
    Posts
    3,582
    Like
    2
    Liked 3 in 3 posts

    Default Re: Mondeo Screen Wash Problem

    Quote Originally Posted by littleredrooster View Post
    If it's the same as the later Mundanos, there's only one pump which spins one way for the front jets, and t'other way for the rear jet. So it could either be a blockage in the outlet from the pump (likely) or summat in the motor/impellor letting it spin in only one direction (possible) or an electrical fault with the motor (less likely).
    +1
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!

  16. #15
    Retired. Yorick's Avatar
    Join Date
    Jan 2008
    Location
    Too Fast For Neil Hodgson
    Posts
    22,279
    Like
    48
    Liked 62 in 50 posts

    Default Re: Mondeo Screen Wash Problem

    Quote Originally Posted by littleredrooster View Post
    If it's the same as the later Mundanos, there's only one pump which spins one way for the front jets, and t'other way for the rear jet. So it could either be a blockage in the outlet from the pump (likely) or summat in the motor/impellor letting it spin in only one direction (possible) or an electrical fault with the motor (less likely).
    That sounds good as the rear is a bit weaker than normal.

    Thanks all
    Register to join this UK Motorbike Forum, start a motorbike blog, or use our free motorbike classifieds!

Page 1 of 2 12 LastLast
Go Back to Forum My Forum