TRC is primarily funded by ad revenue. If you like the content you find here, don't block the ads check them out instead. Thank you.
Results 1 to 8 of 8

Thread: Moto Guzzi woe

  1. #1
    Should Get Out More Savio Du Funk's Avatar
    Join Date
    Oct 2008
    Posts
    13,100
    Like
    0
    Liked 3,567 in 1,274 posts
    Blog Entries
    10

    Default Moto Guzzi woe


    TRC is primarily funded by ad revenue. If you like
    the content you find here, don't block the ads check
    them out instead. Thank you.
    Battery flat. Thatís ok, not used the bike for months.

    Charge. Fires up. Ride to petrol station 5 minutes away. Wonít start. Jump off car, starts.

    Ride for an hour at Ďmaking progressí speeds.

    Pull up and fill up. Wonít start. Jump again


    Any ideas? Is the alternator shagged? Could it just be the battery is toast?

    Many thanks

  2. #2
    Should Get Out More DefTrap's Avatar
    Join Date
    Jan 2008
    Location
    Roger Barlow's Tour of Europe
    Posts
    23,823
    Like
    2,669
    Liked 2,540 in 1,512 posts

    Default Re: Moto Guzzi woe

    Nearly always a new battery required. When they're fooked they just dont hold charge.

  3. #3
    Should Get Out More KungFooBob's Avatar
    Join Date
    Aug 2012
    Location
    The Forest Moon of Endor
    Posts
    15,871
    Like
    381
    Liked 6,887 in 3,896 posts

    Default Re: Moto Guzzi woe

    I'll 2nd battery.

    Exactly the same happened with my olde Varadero.

    I was on a tour of Ireland at the time and the wife got quite proficient at pushing. New battery fixed it.

  4. #4
    Should Get Out More a_morti's Avatar
    Join Date
    Jan 2008
    Location
    Gibraltar
    Posts
    11,910
    Like
    1,418
    Liked 1,054 in 679 posts

    Default Re: Moto Guzzi woe

    Another +1

    If it ran for an hour after needing a bump start then your alternator etc is fine. Just a battery. Bike won't necessarily enjoy running just off the alternator for any length of time, get batt sorted.

  5. #5
    Really Bored whysub's Avatar
    Join Date
    Jan 2008
    Location
    In The Essex Countryside
    Posts
    3,480
    Like
    454
    Liked 239 in 129 posts

    Default Re: Moto Guzzi woe

    My Guzzi V 1200 Sport did the same last year. Thought that I was going to have to replace it for the 3rd time. Nope, it was still o the original, not bad as it was often not used for months and had been fast charged from dead flat many times.

  6. #6
    Should Get Out More nidge's Avatar
    Join Date
    Jan 2008
    Location
    Oxford
    Posts
    5,921
    Like
    1,475
    Liked 2,053 in 936 posts

    Default Re: Moto Guzzi woe

    Easy to check if itís charging. Put your multimeter across the terminals and see if the volts rise with revs. I suspect itís just the battery but I would check charging just in case before shelling out on a new one

  7. #7
    Should Get Out More RiceBurner's Avatar
    Join Date
    Jan 2008
    Location
    Hiding in your blind spot...
    Posts
    14,658
    Like
    3,620
    Liked 1,378 in 787 posts

    Default Re: Moto Guzzi woe

    Quote Originally Posted by nidge View Post
    Easy to check if it’s charging. Put your multimeter across the terminals and see if the volts rise with revs. I suspect it’s just the battery but I would check charging just in case before shelling out on a new one

    This is Savio..... His next post would be about the major fire that took out the entire street.

  8. #8
    At Work iansoady's Avatar
    Join Date
    Feb 2008
    Location
    Birmingham
    Posts
    1,162
    Like
    121
    Liked 297 in 148 posts

    Default Re: Moto Guzzi woe

    It's worth also checking the terminals for security / corrosion. May save you the cost of a battery (this year at least). But I agree that's most likely.

Go Back to Forum My Forum

TRC Affiliates - Help TRC make a small amount of commission